Problems Pop Up With the PS4

Before you go, we thought you'd like these...
Before you go close icon

Uh oh. Technically the PS4 isn't even out yet, but already we're getting a few reports in that some people that were using early release versions are having a few problems.

It's not loads, let's be clear, but according to the CVG report, at least four systems have thrown up problems. Two of these come from review websites and another two from those who won them in competitions - bummer for those guys.
The first one had issues with its HDMI port, where the cable wouldn't go in far enough to receive the video and audio signal. Similarly, one reddit user who won a PS4 from a Sony/Taco Bell promotion found that his console sent no signal to the TV either, but it could be something a little more complicated, as the machine doesn't seem to boot up properly either.

Watch him struggle to get it to connect here.

IGN also had some problems with one of its review units, where it broke down and refused to operate soon after applying the 1.5 patch. Before that it worked fine, but afterwards, it refused to boot and send a signal to the TV, just like the competition winner.

The final person reporting problems had issues getting his account to login, but fortunately was able to get past it after a few tries - suggesting his issue was a little less serious than the others.

While this is of course no indication that this sort of fail rate will be present in the retail versions of the PS4, I'd imagine there's more than one executive that's sweating bullets right now hoping that everything pans out alright tomorrow.

Read Full Story

From Our Partners