Trouble loading FrontierVille? Update your Flash player, says Zynga

Before you go, we thought you'd like these...
Before you go close icon
Adobe Flash PlayerAccording to several FrontierVille forum-goers and FrontierVille Info readers, the game was experiencing significant issues yesterday from playing the game effectively to loading it at all. Of course, it garnered the attention of the Zynga community team. FrontierVille forum moderator NikkiKing posted on the forums in response, "Effective 1/25/11 you will need to have the latest version of Adobe® Flash® Player installed in order to play FrontierVille."

She then provided a link a to the Adobe Flash Player download website, which you can also find here. But for Google Chrome users, don't even worry about it--Chrome updates its built-in Flash plug-ins automatically. Personally, I didn't even notice the issue because I always have my Flash player up to date, because, well, it's my job. This is certainly not the first time the game has experience Flash-related performance issues. (Though it has gotten better.) Hopefully this will solve the headaches once and for all. And from here on out, be sure to keep abreast of Flash player updates if you want a near-seamless experience on the homestead.

[Image Credit: Apple]

Did you experience performance issues yesterday? Did updating your version of Flash Player help? Let us know in the comments. Add Comment.
Read Full Story

Sign up for Breaking News by AOL to get the latest breaking news alerts and updates delivered straight to your inbox.

Subscribe to our other newsletters

Emails may offer personalized content or ads. Learn more. You may unsubscribe any time.

From Our Partners